Ubuntu 17.10 64bit alphanet easy run


1.) download https://www.ubuntu.com/desktop/1710 and setup.
open terminal
Please copy/paste the following commands


sudo apt-get update


sudo apt-get install
> apt-transport-https
> ca-certificates
> curl
> software-properties-common


sudo apt-get install curl


curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -


sudo add-apt-repository
“deb [arch=amd64] https://download.docker.com/linux/ubuntu
$(lsb_release -cs)


sudo apt-get update


sudo apt-get install docker-ce


sudo usermod -a -G docker “YourUserName”

logof user and logon…


docker run hello-world

(for test… )


wget https://raw.githubusercontent.com/tezos/tezos/alphanet/scripts/alphanet.sh


chmod +x alphanet.sh


./alphanet.sh start

Good luck and have fun…


good job!

have you tried Ubuntu (core?) on Arm64 based machines or RPI3?


ran the system with PR3. but I need a platform, for learn more.
because I’m first time working on a POS system
I dont know what is baker, endorser, identity, etc etc. or how to work?
I need learn more.


so you managed to install and run Ubuntu-docker-alphanet.sh on RPI3? that’s fantastic! At some point it would be great if you post some notes. Some people tried earlier and failed.
To learn more about Tezos at large perhaps you want to start here http://doc.tzalpha.net/ and follow the links


how much space is needed? i tried on vps but out of space when installing curl… ahahha


I appreciate your work. I would be an example of someone that needs basic knowledge and everything is way over my head. for example, once the ubuntu 17.10 is finished dl’ing, the first three options of where to restore image? doesn’t work.
I’m working w a librem 15 and “lost in the sauce”
it asks me where to restore image? i have 3 options 1) 120GB disk - BIWiN SSD
2) 2.0GB Block Device
3) 115GB Block Device
error messages come up after each selection
I will wait a little while for an answer, not in a rush