Step by step setup of a Raspberry Pi 3 with Fedora linux-OS and Tezos


cleaning up the system to make a neutral image may be tricky, but maybe @demo or @Mootjes007 will do it.
In any case you are lucky because I just got my 3rd RPI3 and before going through a personal installation I wanted to do exactly what you are looking for, a clean neutral image. It is basically done (Tezos is compiled, and the blockchain is downloaded) but before making the image I want to play a bit with a couple of things, let’s say that in few days something should be downloadable somewhere.
On a side note, OCamL compilation is much easier with the latest Tezos, no more drama meandering to find the right dependencies.


great! will keep an ear down! looking forward!



get in touch soon…
and if you still plan to devolve few tzs for the cause, should go to @demo


I dont want many Tzs. One Tz would be enough for me. I just want to get one vote, and be able to participate into the system.


Ok im almost done… lol what an adventure.

im at step T-5 and teh first error im having

at opam install git-unix

it gives me an error "the compilation of conf-gmp failed at “sh exc cc -c $CFLAGS -I/usr/local/include test.c”

is that normal? should i try to make build-deps?


did solved that! now my problem is before the uri problem

the compilation of nocrypto failed "ocaml pkg/ build --pinned false --tests false --jobs 1 --with-lwt true --xen false --freestanding false

now im stuck and dono how to even copy the txt here so you can see it all…


Done! compiled! yayaaay! now opening th eports etc! will keep you posted!


Im stuck on step T-10. trying the it gives me an error once I take the # from #opam depext tezos from, when i “make build-deps” gives me

The following command needs to be run through “sudo”:
rpm -q pkgconfig
Allow ? [Y/n] n
make: *** [Makefile:20: build-deps] Error 1 so have not found a way to do make clean them make.

I did change the stanzas but dono if i did change them properly… i finish and have compile but dono if the node is working propertly, i will be testing tomorrow


wow, almost done, impressive,
the last problem you have with “pkgconfig” is easy to fix (T-6). Open the file “” located in /home/<user>/tezos/script and comment the line “opam depext tezos”.
Then try again "make build-deps"
Most likely you’ll see a package missing. You’ll have to install it manually with:
opam install cohttp-lwt-unix

Have you pinned locally the package uri.1.9.6? In my notes I mentioned uri.1.9.5 but the new version of Tezos (as of last week) needs the updated version 1.9.6 (changes to the stanzas still apply).

Good news about the OS+Tezos image for RPI3. I made it yesterday but I want to add some few changes then repackage it and put it somewhere probably later today. It may take some time to upload though (~4GB).


Looking forward to downloading it and test it :slight_smile:


@maxtez-raspbaker also running into troubles on the tezos-client… can you copy your config.json my client is not connecting to the node…

trying to install my second Rasp3, did you use 4.06 for the new build? i got a lot of errors just from installing from yesterday to today, dono what is going on but it is crazy.

∗ installed conf-perl.1
∗ installed conf-pkg-config.1.0
[ERROR] The compilation of conf-which failed at “which which”.
∗ installed mirage-no-solo5.1
∗ installed mirage-no-xen.1
∗ installed num.0
[ERROR] The compilation of conf-libev failed at “sh ./”.
∗ installed conf-leveldb.1
[ERROR] The compilation of conf-openssl failed at “pkg-config openssl”.
∗ installed ocamlfind.1.7.3-1
∗ installed base-bytes.base
∗ installed ocamlbuild.0.12.0
∗ installed calendar.2.03.2
[ERROR] The compilation of kaputt failed at “make all”.
∗ installed jbuilder.1.0+beta18
∗ installed base64.2.2.0
∗ installed ocamlgraph.1.8.8


@greenfairy mmm, I need more info, you are saying that the tezos-node program is running fine but tezos-client is giving you some kind of error? not sure that config.json will help, the only part that could cause trouble is the definition of the ports. Below here is the part of the config.json file with the default ports numbers, you don’t really need it since they are the default ports!. The file may be useful when you are using alternative ports, if that is the case, then change the numbers in the file accordingly.

About your new compilation, yes it is quite crazy. Ok, you still need to use OCaml version 4.04.2. Then the first time you run the command “make build-deps”, make sure that in the file /home/<user>/tezos/script/ the line “opam depext tezos” is not commented. You’ll comment it later but first the script should install a bunch of packages. In my note I mentioned that the package uri.1.9.5 needs to be pinned locally. It is still the case but the version is different, now Tezos works with uri.1.9.6.

I am uploading now the image (OS+precompiled Tezos for RPI3) on google drive, awfully slow, it says more than ~14hrs before it is completed.

  "rpc": {
    "listen-addr": "localhost:8732"
  "net": {
"bootstrap-peers": [
"listen-addr": "localhost:9732"


send you a PM my reddit account!



yes the port Im using are 33 not 32, so i have done the router forwarding, after i did T-11. I didnt do F-8 to F-14 i coudl not make work the F-11 static hostname, but if it is necessary I will try again to make it work.

I did change the config file that is under ./tezos-client to the right port still no luck.

[jose@tezcomputer4 tezos]$ ./tezos-client --port 8733 network stat
Ignored error:
Failed to acquire the protocol version from the node
Cannot contact RPC server: Connection refused
Unrecognized command. Try using the ‘man’ command to get more information.


@greenfairy don’t worry about the hostname, it only matters for the setup of the ssh server.
Question: you have internet access on the RPI3 right (ping works fine)? can you run the tezos-node? if yes do you see on the screen something like this:
date time node.validator. net: update current head…
If you haven’t seen it before then run the node first and wait to launch the tezos-client until the node start syncing.
If you have seen the text above, then let’s move to other options. Maybe stop the firewall (temporarily) just type as a root systemctl stop firewalld then I would also look into the router and remove any firewall there as well. Some routers have a Demilitarized Zone option, which removes all possible restrictions.
I am quite sure that one of these steps will help identify the problem with the RPC connection.


yes the node is running i get few connections (4) at the begining but then after sometime it gets into date time head etc, so i know is running.

I will stop the firewall on the RPI and fiddle with the router DMZ, will let you know once i get far into it!



any luck solving the RPC connection problem? the node is running which is very good, then it must be something either in the router or the firewall. The other possibility, quite remote, is that something got mixed up with the file ownership and permissions. But if everything was compiled as a <user> and tezos is a sub-folder in <user> then it should be fine.
By the way, congratulations on compiling Tezos on RPI3, you are one of the few, at least that I know…


@maxtez-raspbaker not yet! i have done all the changes to the router then re-check everything in the RPI, no luck, probably something did go wrong with the compile as you said. i tried to recompile and all is good until befor the uri, then all breaks again… will try again and see where that takes me.

I did downloaded the compiled image from reddit and the client works also, it has been not rock solid and game me an error when i did try to transfer 100k to my_identity and gave me:

my command: ./tezos-client transfer 100,000.00 from freetezos1 to firstacc -fee 0.00

fatal error:
RPC request failed:
HTTP status: 404 (Not Found)

Does that happens to you? any clue of what is going on?


the RPC problem is really strange, from what you wrote, the program tezos-client did start, which means you compiled it correctly, that is you have a green tezos-client file in the folder /tezos.
The compiled Tezos that I put in the image file was created about the same time as you did, that also means that the compilation is doable.
One more thing is to look at the “config” file in the folder /.tezos-client. The file is created automatically, and it supersedes any flag you add when launching tezos-client. For example if the port in the file “config” is 8732 and you run the command “tezos-client -port 8733 launch daemon” the actual port is 8732 not 8733. Worth checking…

About your transfer problem see the last faq here:

In another faq on the same page (“connection refused” error) it is also mention that a compiled tezos-client must first start on port 8732. I don’t think that’s true.


@maxtez-raspbaker, ok my compile version on the rpi3 launched the client and went as far as with the reddit image one, but in both cases i get stomp, i can create an identity, and i can get some play tezos, but when i get started in the process of delegating and transferring tezzies gives me the following:

./tezos-client get delegate for justgivemesome
Fatal error:
RPC Request failed:
HTTP status: 404 (Not Found)


./tezos-client set delegate for justgivemesome to Josteztest
Fatal error:
RPC Request failed:
HTTP status: 404 (Not Found)


./tezos-client transfer 50,000.00 from justgivemesome to Josteztest
Fatal error:
RPC Request failed:
HTTP status: 404 (Not Found)

Im starting to think it has something to do with my router on that address ( also my compiled version also runs faster and smoother than the reddit image you posted there, dono why. teh only difference is teh sd card size and some things i didn’t installed in my compile version…


From what I read zeronet will handle RPC requests much better.
With 2 running RPI3 you can now look at the ram usage over time, and compare the effect of different config.json files and kernel parameters