Step by step setup of a Raspberry Pi 3 with Fedora linux-OS and Tezos


I am posting here a link ( to my detailed notes on how to configure Fedora server (minimal) and compile Tezos on a Raspberry Pi 3 model B. It works! but still more tuning is needed…

Here there is also an alternative link:!/files/SNU3WznxglnaiV6BhviW

My apologies in advance if I won’t reply to all the questions or issues that may follow up this post. I am sure someone with more experience than me will come forward with good suggestions.

However I am interested to get feedback on your experience of running a Tezos node on a Raspberry PI 3 in particular about the working configuration, CPU resources allocated for the service and number of allowed peer connections.

I’ll try to revise the notes from time to time.


ps the link to the first platform (bold) is legit but no longer supported, the certificate is expired, that is why the warning about not secure connection even though it is safe (I think). In any case I am adding a third link in a follow up post.


Thanks for posting. I have 2 Raspberry Pi, hopefully 1 is a Pi 3.


…here is a third link:!provider=gist&gistId=de093464b378455ed9a32958f4c57364&


I go now to buy a rasberry pi 3


more people give it a try, better chance we have to get the Raspberry PI doing something good for Tezos. Just keep in mind that 1) to get the little thing up and running may take some time (I guess that’s what the holidays are for) 2) some tuning is still needed. I have two machines running right now but only linked to 5-6 peers.


Hey Max - I spent a couple more hours today in trying to compile it on RHEL/RP3b and got again a bit further.

Long log:

This is what I did.

  1. I followed your advice from Reddit.
  1. when running ‘make build-deps’, it said Ocaml was not found. I went to open the build-deps file (vi and commented ‘exit 1’. After that the build ran but in the end resulted in an error (see long log)

Any remaining ideas?

PS: Merry Christmas :wink:


I see some progress, good news, you have compiled successfully uri.1.9.5.

I am a bit puzzled by the “opam switch list”, tezos is set correctly to be the alias of OCaml 4.04.2
but 4.04.2 is not installed, a line like the following is missing:
4.04.2 I 4.04.2 Official 4.04.2 release
Have you tried at the beginning of the installation: opam init --comp= 4.04.2

Removing exit 1 in ‘make’ gets you a free pass with an unknown compiler version,
I am not sure how this affects the outcome.
Maybe it would be safer to delete the folder /home/mootjes/.opam and put the right version in place:
opam init --comp= 4.04.2
opam switch “tezos” --alias-of 4.04.2
eval opam config env
make build-deps

The long screenshot shows that at the end you have a problem with two packages.
If the trouble persists even with the correct compiler, try:
opam depext conf-libev.4-11
opam depext conf-openssl.1

The first package (conf-libev.4-11) may need another library, maybe this should help:
sudo dnf install libev
For the second package (conf-openssl.1) I am not sure what is the problem, maybe type:
opam install conf-openssl.1
and if it doesn’t compile correctly, see the error message at the end.

you are almost there…
…and Happy Christmas to you too


Can you suggest another method to burn the Fedora ARM image to sd card in Windows 7 other than Etcher?
Can’t get that to work on Win 7 or 10 for some reason.


not even the portable version? it should work for both 32 and 64 windows.
“Win32 Disk Imager” is an alternative:


Hey Max - thanks for your reply. After a lot (!) of retries I decided to give it a shot on Ubuntu Mate. I’ve gotten quite far! But still got stuck :slight_smile:

FYI, something I learned: I know why I couldn’t run ‘ocaml’: for some reason I had to input ‘eval opam config env’ again. Then it recognises.

As for the installation on Ubuntu Mate raspberry pi:

  1. installed Opam + ocaml

  2. I followed your procedure on T-7) to adapt the stanzas (step 3 wouldn’t work without it): resulting jbuilds (hope it’s correct):

  3. I was able to run ‘make build-deps’

  4. on ‘make’ I got an error: (contains end of ‘make build-deps’ + ‘make’ at the very end)

Do you have any final hints? Hope I’m getting close now!


If it is of any consolation, it took me much longer to get to the point where you are now.

Your issue with ‘make’ is a new one for me. After saying that I am not an OCaml programmer, I looked at the incriminated file “” line 194, it seems to me that the line deals with the integer definition for 32bit machines. Since you have a 64 processor with a 64bit OS (Ubuntu Mate) I would boldly comment lines 194-195 and see what happens. The location of the file is /home/mootjes/.opam/tezos/

Regardless whether the cheap fix will work or won’t do any good, I would contact Milo Davis on github to point out the problem because the file “” has been modified recently. I have an older version that is slightly different and does not include the troubled instructions around line 194 (among other things).

let me know how it goes…


I have an SD disk of 16GB. Is it enough for installing Tezos in my pi3?


Win32 Disk Imager worked. I tried using it before but I incorrectly assumed it could only read .img files. I switched to . and was able to write the image to a 16GB sad card. Thanks!


yes, 16GB is enough, with Fedora minimal + extra packages + Tezos it is ~4GB, adding a couple of GB taken by other stuff, you’ll probably end up with ~10GB free space. Whether 10GB will be enough for staking and baking, I don’t know. I guess one can start small then, in case more space is needed, just clone the SD card into a bigger one


thanks for you answer!
I followed the tutorial step by step.
I am stack now here:
To start X windows type as a user (not root):

$ startx

When I issue the startx command it says:

xauth: file .serverauth.1093 does not exist
xauth: file .Xauthority does not exist
X.Org X Server 1.19.5
Release Date 2017-10-12
X Protocol Version 11, Revision 0
Using system config dir /usr/share/X11/xorg.config.d
Could not open No such file or directory
xinit:giving up

My terminal after this is also messed up, and I need to issue an
stty sane
command in order to fix it.

Whats wrong?
Any hints?

I am using a 42 inches tv as my terminal. Do you think this is the problem?


it could be the tv terminal, maybe try first:
dns upgrade
and then
dnf install libglvnd-egl
the missing library ( should be included in the package libglvnd-egl


ok! I issued the commands
dnf upgrade
dnf install libglvnd-egl

and I entered X11!


I am now in step F10) Basic general instructions to open ports on the modem and router
and I will continue tomorrow.


ok. Now I am stuck in the command
opam init --comp= 4.04.02

Checking forr available resources: Perfect!
[WARNING] aspcud not found
[ERROR] Initialisation failed
Fatal error:

Actually there is not even a .opam directory.
Did you missed something in the insruction?

ok I solve it
it is
opam init --comp=4.04.02

(no spaces between =)


It is very annoying that opam init and opam switch commands perform silenlty.
You dont know whether your pi3 is stuck or not!
I am waiting opam switch at least one hour and nothing happens…
It is stucked in
Processing:[4.04.2:make world]

How long does it take in your pi3?


I think it is doing ok,
“Now compiling OCaml. This may take a while, please bear with us…”