Running a Tezos node on the *alphanet* and the *zeronet* made super-simple (with RPI3)


#61

I was able to boot with fedora minimal, log in as a superuser, and execute the two commands you show. What’s the next step?


#62

@abedit
thanks, this is valuable info.
I was looking at the image that I posted, maybe I found the source of the trouble. I am going to create a new image today. The main problem is that my upload speed is ridiculously slow, it will take several days (6-8 days) to complete the upload of the monster image file (~7GB), unless I find a way to shrink it a bit further.

If you want to continue the setup of Fedora minimal that you have successfully installed, here are some more steps. First, there are some notes that I posted some time ago which can be used as a template.
Right now you are on step F-2) . Before going further I would suggest to create a new user name with this command (as a superuser)
useradd -m tzuser
and then disable ssh (security)
systemctl disable sshd
then you can continue following the notes, you can ignore all the points related to ssh since it is disabled. This would be my recipe:
apply F-3) - F-6)
ignore F-7) - F-15)
apply T-1) - T-2)
If you decide to continue the setup, let me know if you have any problem/question


#63

I’m undertaking the rest of the steps in the notes now. So far so good, except that startx in F-5 seems to time out. I restarted from the very beginning again with Etcher/Fedora, but the same problem occurs. I’ve ignored it and went on to complete your instructions through T-2. What’s the next step?


#64

@abedit
wow that was fast, good progress.
First I have to apologize because the formatting of the old notes was awful. Missing text, missing links, horrible, I tried to fix it a bit (the original version is still here).

Before getting into the installation of OCaml and Tezos, the startx issue should be resolved because you will need a working environment where you can open multiple text shells.
These 3 set of packages have been installed:
dnf groupinstall base-x
dnf install twm
dnf install xorg-x11-apps
then as a user typing startx does not bring up X11 (X-windows graphic interface), is this what happened?
In this case, in the folder /var/log there is a file similar to this Xorg.0.log. It should give some hints on the problem. Maybe I can have a look at it.

If you managed to solve this issue on your own, then you can move to the next step, install OCaml. This page should help. As you’ll see there are also some instructions to compile Tezos.


#65

Yes, that’s correct. I installed the 3 packages and typing startx does not bring up X11. It gives the error unable to connect to X server: Connection refused. The file Xorg.0.log is not under /var/log, but under /home/tzuser/.local/share/xorg.

I’m going to be on travel the next several days and won’t be able to spend time on this unfortunately. In case your new image hasn’t uploaded by the time I return, we can resume.

Thanks again for your work.


#66

oh ok, I see, you have installed the packages as a user (tzuser?), but instead they have to be installed as a root/superuser. Once you fix that, I am sure it will work.

Enjoy your trip, I am afraid the image won’t be ready too soon, I haven’t started the upload yet, trying to do more testing on the zeronet before the official betanet…but I’ll keep you posted…


#67

I thought I’d installed everything as a superuser, but I’ll have to try again later.


#68

yes, I am afraid so, don’t forget to remove the packages (as tzuser) with dnf remove package. Sometimes I get confused too. In general anything that is installed with dnf is done with root privilege. OCaml and Tezos instead will be installed and compiled as tzuser.


#69

@maxtez-raspbaker
1- currently https://www.dropbox.com/s/xytmq80rs4a5akd/tz-zero032618.zip this site are not avilable then how to i create my tezos node ???
2- just i want to create my tezos wallet in my local machine but i can’t do that . so please help me to create my wallet ???
3- how to deploy simple contract in tezos testnetwork ???


#70

@sixface
please visit the RPI3 wiki home, all the updates are there.
You need first to download the image file of Fedora OS (RPI3-TEZOS-050618.img), then the tezos precompiled files. Note that at the moment the OS on the image file does not boot on the new RPI3 B+. I am working on it.
Let me know if you need help.


#71

@maxtez-raspbaker
I want to deploy my tezos contracts so what is the requirements need to deploy my contracts like
hardware and software please answer me…


#73

@sixface
well, if you want to deploy a tezos contract you need access to a tezos node either your own or someone else that gives you access to it via some kind of (web)apps. I am supporting Tezos on Raspberry PI 3B, if that is what you have in mind I am your guy. For installation on other hardware/software there are several resources around, for example here or here.


#74

@maxtez-raspbaker
Currently tezos completely ready to dapp development???


#75

@maxtez-raspbaker
Tell me your answer one of the greatest advantage of Tezos??
Why tezos is better compare to other blockchain technology?


#77

Hello,
I am not really the most qualified person to answer your question since I am not using docker, perhaps @HCLivess has an answer.
Some info here or in the official docs


#78

I finally have some time to get back to the RP B3+. If you have any update, let me know. If not, I’ll start with a clean install of fedora and follow along your previous instructions. Let me know. Thanks.


#79

glad to hear you are not giving up on your RPI3 B+. I posted a new image file but wasn’t good for B+.
There is a new one ready to be uploaded maybe will start today (upload time ~3 days!!), if the new image still won’t work, I may consider to get a B+ for myself so that I can finally find out what is wrong. In the meantime you can wait a bit longer or go ahead with a clean installation of Fedora (other linux OS should be ok, just pick one with a small footprint). As usual, the latest developments are posted on the tezos-rpi3 wiki page


#80

Got it. I’ll wait for 3-4 days for the next image file to upload.


#81

Thanks for all effort on the guide, I’m quite the newbie on rpi’s but still thought I wanted to get started on my Tezos node. Recieved my RPI3 B+ today, and it seems I have the same error on booting? any smart work arounds on this yet? or should I exchange it for a RPI3 B model :)?


#82

@RunUpLandt
welcome to the RPI3 family!, there have been some developments since the last posts on this forum, best place to catch up is the tezos-rpi3 wiki
RPI3B+ should be fine (there are few people working with it) but you’ll need aarch64/armv8 linux, my choice is fedora minimal, other distros should be ok as well, You’ll find the rest of the info on the wiki page.
Please note that the first booting is still a bit problematic, the monitor may get disconnected, wait for few more minutes, then eventually try again. The first time I do a new installation it takes me 2-4 attempts before booting reaches the end. Once it is done, do the OS upgrade right away, as root/administrator type: dnf upgrade then reboot it and the starting process should run much smoother afterwards.
If you need more help let me know…