Cant restore Tezbox Wallet

I was never able to get the wallet application on my computer so was using the online version linked with my ledger nano S. After a change of computer I got locked out of my old wallet.

When I restore using the 15 word seed code it starts a new wallet for me with abalance of zero.

I have tried importing the KT address but it shows error code that it is not linked to this wallet?

I have tried firing up the ledger nano S and simply clicking on link your tezbox link It then asks me to verify the address on my ledger and once i press tick on the ledger nothing happens on the texbox website and i have to press cancel.

I can see my tezos on my address in so i know they are safe i just cant get access!? Any help would be greatly appreciated…

I’m having the same issue. I created the tezbox wallet (though never downloaded to my machine) and initially saw my balance. When I attempted to restore the wallet one month later, I ran into the ‘uh oh’ message suggesting that my pw was incorrect, though it is correct. Have you had any success since your post?

I am having a similar issue by not able to restore my fundraiser wallet.

I remember a year ago trying to restore it using tezbox I believe on my phone and nothing hapoened after entering all the information. So i just deleted the app.

Now I wanted to do it again and I get the same Ups suggesting that the password is probably incorrect although I am 99% sure it isn’t because I have it saved and i tried multiple different variations also.

If I just try restoring using my seed it crrates a different wallet with zero balance although all balance is still seen on my public hash?

I am wondering what can I do at this point.

I also tried restoring with Galleon but I get the same results.

Hello @Rozzeto. Had your issue been resolved ?

Hi mate . Has your issue been resolved yet ?